Automatic disconnect

If you think you have found a bug...

Moderator: drgrussell

Post Reply
Rocket
Posts: 1
Joined: Mon Sep 09, 2013 4:14 am
Are you a robot or a human?: Human

Automatic disconnect

Post by Rocket » Mon Sep 09, 2013 4:23 am

No one is in queue !
I am given 20 minutes but it automatically disconnects after 5-6 minutes.. Annoying !

drgrussell
Site Admin
Posts: 426
Joined: Sat Feb 12, 2005 8:57 pm
Are you a robot or a human?: Human

Re: Automatic disconnect

Post by drgrussell » Mon Sep 09, 2013 10:24 am

You are disconnected for a number of reasons...

Sure if it is busy you will be dequeued after around 10-20 minutes. Confirmed email users get 20, and unconfirmed email gets 10. My own students have better priorities and timeouts of course, but this is a free service in general. But when the server is low-loaded this should never happen to any user, as when the timeout reaches 5 minutes is freezes if the machine is only moderately loaded.
You are also disconnected if you have no ssh/telnet/vnc connection for 4 minutes.
Your actual ssh or telnet connection can timeout due to the default linux timeout and idle settings.
You will be dequeued after 1.5 minutes if you do not have a browser window on a linuxzoo page with a control panel on it (i.e. the top right window with the power on button).

You mentioned that there was noone in the queue, but there never is. Instead once the available machines which match your permissions have more than about 50% usage then you are considered to be in a moderate-load situation. This it is very very rare even during busy times to have to queue.

Having said all that, I can almost guess you were timed out for navigating away from linuxzoo or not typing into your command window.
I need these timeouts, otherwise free users come and boot machines then forget to shut them down, and that uses up the resource rapidly.

Best regards
Gordon.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest