by pressing the up arrow...

If you think you have found a bug...

Moderator: drgrussell

Post Reply
alexh
Posts: 5
Joined: Wed Nov 19, 2008 5:31 pm

by pressing the up arrow...

Post by alexh » Thu Nov 20, 2008 11:17 pm

Hello!
When I'm logged in as root and I press the up arrow to go back in the command line history, I get disconnected (see screenshot)

Image

When logged in as user demo, the deconnection does not happen.
I'm running Ubuntu 8.10 and I haven't tried yet from the Uni. I won't be there until monday.

I'm currently doing the firewall tutorial.

Not sure it comes from the VM or not: 8.10 is still a young version and is still quite buggy...

alexh
Posts: 5
Joined: Wed Nov 19, 2008 5:31 pm

Post by alexh » Sat Nov 22, 2008 11:01 pm

I might add also that since I've moved over to the DNS tutorial, it doesn't happen anymore...
Weird...

drgrussell
Site Admin
Posts: 426
Joined: Sat Feb 12, 2005 8:57 pm
Are you a robot or a human?: Human

Post by drgrussell » Wed Nov 26, 2008 9:42 pm

I have never heard of this happening before. It would be lovely to capture the packets involved and see what was really happening. However, it is likely a bug in your telnet program... I am told it also happens to some xp telnet clients.

One solution is to use putty. Google putty and download putty.exe. It is a stand-alone executable and does telnet as well as ssh. I recommend it 100%. You can use ssh with linuxzoo.net

Another option might be to change the terminal type when you log in. Try typing this each time you log in:

$ export TERM=vt100
$ tset

If the problem persists with this setting then I am out of ideas. It has never happened to me.

Sorry
Gordon.

alexh
Posts: 5
Joined: Wed Nov 19, 2008 5:31 pm

Post by alexh » Mon Dec 01, 2008 12:25 am

Thanks! It's been fixed apparently. I've just been through the firewall tut again and didn't encounter any probs.
Thank you for your time!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest